Issues with general internet access on site at Fordham
Incident Report for LIFE Education Trust
Resolved
We are happy to announce that any issues regarding general internet access on site at Fordham have now been resolved and expected service has now been restored.
Posted Nov 19, 2024 - 23:52 GMT
Investigating
We are currently investigating issues regarding general internet access on site at Fordham and will update this thread as soon as we have more information.
Posted Nov 19, 2024 - 23:51 GMT