On Site Network Performance Issues - Frances Bardsley Academy for Girls
Incident Report for LIFE Education Trust
Resolved
We are happy to inform you that the on site connectivity issues have now been resolved and internet service should be restored to expected levels.
Posted Oct 11, 2024 - 20:00 BST
Investigating
We're are currently investigating issues regarding internet connectivity on site at The Frances Bardsley Academy for Girls and will update this thread as soon as we have more information.
Posted Oct 04, 2024 - 10:12 BST