Issues with Fordham Wireless Network
Incident Report for LIFE Education Trust
Resolved
We are happy to announce that any issues regarding Fordham Wireless Network have now been resolved and expected service has now been restored.
Posted Oct 19, 2024 - 02:49 BST
Investigating
We are currently investigating issues regarding Fordham Wireless Network and will update this thread as soon as we have more information.
Posted Oct 19, 2024 - 02:45 BST