Issues with Chappel Internet Access
Incident Report for LIFE Education Trust
Resolved
We are happy to announce that any issues regarding Chappel Internet Access have now been resolved and expected service has now been restored.
Posted Oct 18, 2024 - 09:33 BST
Investigating
We are currently investigating issues regarding Chappel Internet Access and will update this thread as soon as we have more information.
Posted Oct 18, 2024 - 09:33 BST