Resolved - Issues with Frances Bardsley Internet Access
Incident Report for LIFE Education Trust
Resolved
We are happy to announce that any issues regarding Frances Bardsley Internet Access have now been resolved and expected service has now been restored.
Posted Oct 17, 2024 - 15:17 BST