Issues with accessing the Margaretting Primary School website

Incident Report for LIFE Education Trust

Resolved

We are happy to announce that any issues regarding accessing the Margaretting Primary School website have now been resolved and expected service has now been restored.
Posted Jul 01, 2025 - 06:44 BST

Investigating

We are currently investigating issues regarding accessing the Margaretting Primary School website and will update this thread as soon as we have more information.
Posted Jul 01, 2025 - 06:44 BST