Issues with Bridge Internet Access
Incident Report for LIFE Education Trust
Resolved
We are happy to announce that any issues regarding Bridge Internet Access have now been resolved and expected service has now been restored.
Posted Oct 21, 2024 - 14:47 BST
Investigating
We are currently investigating issues regarding Bridge Internet Access and will update this thread as soon as we have more information.
Posted Oct 21, 2024 - 14:38 BST