Issues with Bridge Wireless Network
Incident Report for LIFE Education Trust
Resolved
This incident has been resolved.
Posted Oct 22, 2024 - 12:32 BST
Investigating
We are currently investigating issues regarding Bridge Wireless Network and will update this thread as soon as we have more information.
Posted Oct 21, 2024 - 14:39 BST